Screen - Email delivery temporary delay

Incident Report for CoderPad

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 06:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 05:09 PDT

Identified

We are currently experiencing delays in email delivery due to a temporary service disruption with our email infrastructure provider. This affects candidate invitations, user invitations, and report emails.
Our team is actively working with our upstream provider to resolve the underlying issue. All queued emails will be automatically delivered once service is restored.
Posted Sep 02, 2025 - 01:59 PDT
This incident affected: Web Tier.